1 분 소요

1. 문제

https://www.acmicpc.net/problem/2920

  • 배열, 구현문제
// 문제
다장조는 c d e f g a b C,  8 음으로 이루어져있다.
 문제에서 8 음은 다음과 같이 숫자로 바꾸어 표현한다.
c는 1, d는 2, ..., C를 8 바꾼다.

1부터 8까지 차례대로 연주한다면 ascending,
8부터 1까지 차례대로 연주한다면 descending,
  아니라면 mixed 이다.

연주한 순서가 주어졌을 ,
이것이 ascending인지, descending인지,
아니면 mixed인지 판별하는 프로그램을 작성하시오.

// 입력
첫째 줄에 8 숫자가 주어진다.
 숫자는 문제 설명에서 설명한 음이며,
1부터 8까지 숫자가  번씩 등장한다.

// 출력
첫째 줄에 ascending, descending, mixed  하나를 출력한다.

// 예제 입력 1
1 2 3 4 5 6 7 8

// 예제 출력 1
ascending

// 예제 입력 2
8 7 6 5 4 3 2 1

// 예제 출력 2
descending

// 예제 입력 3
8 1 7 2 6 3 5 4

// 예제 출력 3
mixed


2. 핵심 아이디어

  • 리스트에서 원소를 차례대로 비교
  • 비교할 때 두 원소를 기준으로 오름차순 / 내림차순 여부를 체크


3. Python 문제풀이

import sys

a = list(map(int, sys.stdin.readline().split()))

ascending = True
descending = True

for i in range(1, 8) :
  if a[i] > a[i - 1] :
    descending = False
  elif a[i] < a[i - 1] :
    ascending = False

if ascending :
  print('ascending')
elif descending :
  print('descending')
else :
  print('mixed')


4. Java 문제풀이

import java.util.Scanner;

class Main {
  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    int[] a = new int[8];
    for (int i = 0; i < a.length; i++) {
      a[i] = sc.nextInt();
    }
    sc.close();

    boolean ascending = true;
    boolean descending = true;

    for (int i = 1; i < a.length; i++) {
      if (a[i] > a[i - 1]) {
        descending = false;
      } else if (a[i] < a[i - 1]) {
        ascending = false;
      }
    }

    if (ascending) {
      System.out.println("ascending");
    } else if (descending) {
      System.out.println("descending");
    } else {
      System.out.println("mixed");
    }
  }
}

댓글남기기