[Baekjoon] 17406번 : 배열 돌리기4
1. 문제
https://www.acmicpc.net/problem/17406
- DFS, 탐색 문제
// 문제
크기가 N×M 크기인 배열 A가 있을때,
배열 A의 값은 각 행에 있는 모든 수의 합 중 최솟값을 의미한다.
배열 A가 아래와 같은 경우 1행의 합은 6, 2행의 합은 4, 3행의 합은 15이다.
따라서, 배열 A의 값은 4이다.
1 2 3
2 1 1
4 5 6
배열은 회전 연산을 수행할 수 있다.
회전 연산은 세 정수 (r, c, s)로 이루어져 있고,
가장 왼쪽 윗 칸이 (r-s, c-s),
가장 오른쪽 아랫 칸이 (r+s, c+s)인 정사각형을
시계 방향으로 한 칸씩 돌린다는 의미이다.
배열의 칸 (r, c)는 r행 c열을 의미한다.
예를 들어, 배열 A의 크기가 6×6이고,
회전 연산이 (3, 4, 2)인 경우에는 아래 그림과 같이 회전하게 된다.
A[1][1] A[1][2] → A[1][3] → A[1][4] → A[1][5] → A[1][6]
↑ ↓
A[2][1] A[2][2] A[2][3] → A[2][4] → A[2][5] A[2][6]
↑ ↑ ↓ ↓
A[3][1] A[3][2] A[3][3] A[3][4] A[3][5] A[3][6]
↑ ↑ ↓ ↓
A[4][1] A[4][2] A[4][3] ← A[4][4] ← A[4][5] A[4][6]
↑ ↓
A[5][1] A[5][2] ← A[5][3] ← A[5][4] ← A[5][5] ← A[5][6]
A[6][1] A[6][2] A[6][3] A[6][4] A[6][5] A[6][6]
회전 연산이 두 개 이상이면, 연산을 수행한 순서에 따라 최종 배열이 다르다.
다음은 배열 A의 크기가 5×6이고,
회전 연산이 (3, 4, 2), (4, 2, 1)인 경우의 예시이다.
1 2 3 2 5 6
3 8 7 2 1 3
8 2 3 1 4 5
3 4 5 1 1 1
9 3 2 1 4 3
배열 A
1 8 2 3 2 5
3 2 3 7 2 6
8 4 5 1 1 3
3 3 1 1 4 5
9 2 1 4 3 1
(3, 4, 2) 연산 수행 후
1 8 2 3 2 5
3 2 3 7 2 6
3 8 4 1 1 3
9 3 5 1 4 5
2 1 1 4 3 1
(4, 2, 1) 연산 수행 후
1 2 3 2 5 6
3 8 7 2 1 3
8 2 3 1 4 5
3 4 5 1 1 1
9 3 2 1 4 3
배열 A
1 2 3 2 5 6
3 8 7 2 1 3
3 8 2 1 4 5
9 4 3 1 1 1
3 2 5 1 4 3
(4, 2, 1) 연산 수행 후
1 8 2 3 2 5
3 8 2 7 2 6
3 4 3 1 1 3
9 2 1 1 4 5
3 5 1 4 3 1
(3, 4, 2) 연산 수행 후
배열 A에 (3, 4, 2), (4, 2, 1) 순서로 연산을 수행하면
배열 A의 값은 12, (4, 2, 1), (3, 4, 2) 순서로 연산을 수행하면 15 이다.
배열 A와 사용 가능한 회전 연산이 주어졌을 때,
배열 A의 값의 최솟값을 구해보자.
회전 연산은 모두 한 번씩 사용해야 하며, 순서는 임의로 정해도 된다.
// 입력
첫째 줄에 배열 A의 크기 N, M, 회전 연산의 개수 K가 주어진다.
둘째 줄부터 N개의 줄에 배열 A에 들어있는 수 A[i][j]가 주어지고,
다음 K개의 줄에 회전 연산의 정보 r, c, s가 주어진다.
// 출력
배열 A의 값의 최솟값을 출력한다.
// 제한
3 ≤ N, M ≤ 50
1 ≤ K ≤ 6
1 ≤ A[i][j] ≤ 100
1 ≤ s
1 ≤ r-s < r < r+s ≤ N
1 ≤ c-s < c < c+s ≤ M
// 예제 입력 1
5 6 2
1 2 3 2 5 6
3 8 7 2 1 3
8 2 3 1 4 5
3 4 5 1 1 1
9 3 2 1 4 3
3 4 2
4 2 1
// 예제 출력 1
12
2. 핵심 아이디어
- 회전 연산의 개수가 많지 않으므로, 완전 탐색 이용
3. Python 문제풀이
import sys
input = sys.stdin.readline
from copy import deepcopy
n, m ,k = map(int, input().split())
a = [list(map(int, input().split())) for _ in range(n)]
q = [tuple(map(int, input().split())) for _ in range(k)]
dx, dy = [1, 0, -1, 0], [0, -1, 0, 1]
result = 10000
def value(arr) :
return min([sum(i) for i in arr])
def convert(arr, qry) :
(r, c, s) = qry
r, c = r - 1, c - 1
new_arr = deepcopy(arr)
for i in range(1, s + 1) :
rr, cc = r - i, c + i
for w in range(4) :
for d in range(i * 2) :
rrr, ccc = rr + dx[w], cc + dy[w]
new_arr[rrr][ccc] = arr[rr][cc]
rr, cc = rrr, ccc
return new_arr
def dfs(arr, qry) :
global result
if sum(qry) == k :
result = min(result, value(arr))
return
for i in range(k) :
if qry[i] :
continue
new_arr = convert(arr, q[i])
qry[i] = 1
dfs(new_arr, qry)
qry[i] = 0
dfs(a, [0 for i in range(k)])
print(result)
4. Java 문제풀이
import java.util.*;
public class Main {
static int[][] board;
static int[][] rotation;
static int min = Integer.MAX_VALUE;
static int n, m;
static boolean[] visited;
static int[] result;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
n = sc.nextInt();
m = sc.nextInt();
int k = sc.nextInt();
board = new int[n][m];
for (int i=0; i<n; i++) {
for (int j=0; j<m; j++) {
board[i][j] = sc.nextInt();
}
}
rotation = new int[k][3];
for (int i=0; i<k; i++) {
rotation[i][0] = sc.nextInt();
rotation[i][1] = sc.nextInt();
rotation[i][2] = sc.nextInt();
}
visited = new boolean[k];
result = new int[k];
permutation(0, k);
System.out.println(min);
}
public static void permutation(int idx, int k) {
if (idx == k) {
int[][] copy = new int[n][m];
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
copy[i][j] = board[i][j];
}
}
findMin(copy);
return;
}
for (int i=0; i<k; i++) {
if (visited[i] == false) {
visited[i] = true;
result[idx] = i;
permutation(idx + 1, k);
visited[i] = false;
}
}
}
public static void findMin(int[][] copy) {
for (int i=0; i<result.length; i++) {
int lx = rotation[result[i]][0] - rotation[result[i]][2] - 1;
int ly = rotation[result[i]][1] - rotation[result[i]][2] - 1;
int rx = rotation[result[i]][0] + rotation[result[i]][2] - 1;
int ry = rotation[result[i]][1] + rotation[result[i]][2] - 1;
rotate(lx, ly, rx, ry, copy); //lx ly ~ rx ry까지 회전
}
rowcal(copy);//회전한 배열의 최소 행값을 구함
}
public static void rowcal(int[][] copy) {
for (int i=0; i<copy.length; i++) {
int sum = 0;
for (int j=0; j<copy[i].length; j++) {
sum += copy[i][j];
}
min = Math.min(min, sum);
}
}
public static void rotate(int lx, int ly, int rx, int ry, int[][] copy) {
if (lx == rx && ly == ry) {
return;
}
int[] temp = new int[3]; //방향별로 값을 옮기다 보면 지워질 수 있는 좌표값을 저장.
temp[0] = copy[lx][ry];
temp[1] = copy[rx][ry];
temp[2] = copy[rx][ly];
//오른쪽으로 회전
for (int i=ry; i>ly; i--) {
copy[lx][i] = copy[lx][i-1];
}
//아래로 회전
for (int i=rx; i>lx; i--) {
if (i == lx + 1) copy[i][ry] = temp[0];
else copy[i][ry] = copy[i-1][ry];
}
//왼쪽으로 회전
for (int i=ly; i < ry; i++) {
if (i == ry - 1) copy[rx][i] = temp[1];
else copy[rx][i] = copy[rx][i+1];
}
//위로 회전
for (int i=lx; i<rx; i++) {
if (i == rx - 1) copy[i][ly] = temp[2];
else copy[i][ly] = copy[i+1][ly];
}
rotate(lx + 1, ly + 1, rx - 1, ry - 1, copy);
}
}
댓글남기기