1 분 소요

1. 문제

https://www.acmicpc.net/problem/1302

  • 탐색 문제
// 문제
김형택은 탑문고의 직원이다.
김형택은 계산대에서 계산을 하는 직원이다.
김형택은 그날 근무가 끝난 후에,
오늘 판매한 책의 제목을 보면서
가장 많이 팔린 책의 제목을 칠판에 써놓는 일도 같이 하고 있다.

오늘 하루 동안 팔린 책의 제목이 입력으로 들어왔을 ,
가장 많이 팔린 책의 제목을 출력하는 프로그램을 작성하시오.

// 입력
첫째 줄에 오늘 하루 동안 팔린 책의 개수 N이 주어진다.
 값은 1,000보다 작거나 같은 자연수이다.
둘째부터 N개의 줄에 책의 제목이 입력으로 들어온다.
책의 제목의 길이는 50보다 작거나 같고,
알파벳 소문자로만 이루어져 있다.

// 출력
첫째 줄에 가장 많이 팔린 책의 제목을 출력한다.
만약 가장 많이 팔린 책이 여러 개일 경우에는
사전 순으로 가장 앞서는 제목을 출력한다.

// 예제 입력 1
5
top
top
top
top
kimtop

// 예제 출력 1
top

// 예제 입력 2
9
table
chair
table
table
lamp
door
lamp
table
chair

// 예제 출력 2
table

// 예제 입력 3
6
a
a
a
b
b
b

// 예제 출력 3
a

// 예제 입력 4
8
icecream
peanuts
peanuts
chocolate
candy
chocolate
icecream
apple

// 예제 출력 4
chocolate

// 예제 입력 5
1
soul

// 예제 출력 5
soul


2. 핵심 아이디어

  • 가장 많이 등장한 문자열을 출력하는 문제와 동일
  • 등장 횟수를 계산할 때는 파이썬의 Dicionary 자료형을 이용하면 효과적


3. Python 문제풀이

import sys

n = int(sys.stdin.readline())
books = {}

for _ in range(n) :
  book = sys.stdin.readline()
  if book not in books :
    books[book] = 1
  else :
    books[book] += 1

target = max(books.values())
arr = []

for book, number in books.items() :
  if number == target :
    arr.append(book)

print(sorted(arr)[0])


4. Java 문제풀이

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
import java.util.HashMap;

class Main {
  public static void main(String[] args) throws Exception {
    BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
    int n = Integer.parseInt(br.readLine());
    HashMap<String, Integer> map = new HashMap<String, Integer>();
    String str = new String();

    for (int i=0; i<n; i++) {
      str = br.readLine();
      if (map.containsKey(str)) {
        map.replace(str, map.get(str) + 1);
      }
      else {
        map.put(str, 1);
      }
    }

    int max = 0;
    for (String a : map.keySet()) {
      max = Math.max(max, map.get(a));
    }

    ArrayList<String> arr = new ArrayList<String>(map.keySet());
    Collections.sort(arr);

    for (String a : arr) {
      if (map.get(a) == max) {
        System.out.println(a);
        break;
      }
    }
  }
}

댓글남기기